8.3.4.2 Vector: SHP / GML - LUPMISManual

Go to content

Main menu:

8. LUPMIS Tools > 8.3 Processing Tools > 8.3.4 Format conversion

8.3.4.2 Vector: SHP / GML


Level of expertise required for this Chapter: Intermediate; specifically for LUPMIS @ TCPD


These Tools covers all conversion options of SHP and GML formats, in particular for exchange of LUPMIS data in Map Maker with other GIS software:


  • a) Export DRA to SHP

To convert your DRA files of Map Maker to SHP format for QGIS or ESRI software, use this Drawing Tools > Format conversion > Format conversion: Vector > Export DRA to SHP > Single / Many maps.

With the 'Many maps' option you can convert all DRA files in the selected folder. Just pick any DRA file in a folder, and it will convert all DRA files of that folder.



The converted SHP file has the file name as the original with '_conv2SHP' at the end, is saved in the original folder and can be straight loaded in QGIS, e.g. with 'Add vector layer':



or alternatively:





As displayed above, the MM-internal attribute data of id, label and style are automatically transferred to SHP's attribute data

Another example: In Map Maker:



... and converted to QGIS:


- - - - -

Per definition, LUPMIS does not  support attribute data in Map Maker's DBF file. They are therefore not automatically transferred to the SHP format. If for whatever reason, you have entered them into Map Maker, they can be imported to SHP's attributes manually, as explained below.
A temporary data file of Map Maker's attribute data is saved at ..._2CSV.csv in the LUPMIS\LUPMISTemp folder and will be used to 'join' with the already existing attribute data in QGIS. Load this file as a layer in QGIS with Layer > Add Layer > Add Delimited Text Layer

   

Once loaded, you call the properties of the main vector (converted) SHP file: Right-click on the converted layer > Properties > In the 'Layer Properties' window: Joint > + > Join field: ID > Target field: ID > Under 'Check which fields are joined': Check all of your interest (except ID, SPARE, AREA) > OK > OK 

   

In the attribute layer, you will now have both the 'primary attributes' of the DRA file (id, label, style) and the 'joined properties' of Map Maker's attributes:



- - - - -

  • b) Convert SHP to DRA

Similar to the process above, this Tool converts all GML (or SHP) files of other applications to DRA file for use in Map Maker: Drawing Tools > Format conversion > Format conversion: Vector > Convert GML (or SHP) to DRA > Single / Many maps.









It can also be converted back to QGIS:



In general, it is recommended for highest compatibility between Map Maker and QGIS to have the fields of 'style' and 'labels' in all SHP files. ('Id' exists already by default, both in Map Maker and in QGIS). When you start a new vector layer in QGIS, add under 'New attribute' the fields of 'style' and 'labels', as demonstrated below.

            


  • c) Export DRA to GML

GML stands for 'Geography Markup Language' and is an increasingly strong standard for GIS files, based on open-source XML technology and defined by the Open Geospatial Consortium.

To convert your DRA files of Map Maker to GML format for other GIS applications, such as QGIS, GELIS, etc, use this Drawing Tools > Format conversion > Format conversion: Vector > Export DRA to GML > Single / Many maps.

With the 'Many maps' option you can convert all DRA files in the selected folder. Just pick any DRA file in a folder, and it will convert all DRA files of that folder.



In QGIS, you can add it as a vector layer through Layer > Add vector layer > Browse > At bottom right select file type: Geography Markup Language > Select file > OK > Open:



This imported file can now be processed and saved in QGIS. It contains the 'standard attributes' of Map Maker (id, labels, style), but not Map Maker's external attributes, as they are not part of LUPMIS. Nevertheless, they can be imported as explained above for SHP files.
  • d) Convert GML to DRA

In a similar way, GML files can be imported to DRA format for full use in LUPMIS and Map Maker.

  

 
Back to content | Back to main menu