8.1.3.2 Alternative GIS: QGIS - LUPMISManual

Go to content

Main menu:

8. LUPMIS Tools > 8.1 General > 8.1.3 Output
8.1.3.2 Alternative GIS: QGIS

While Map Maker is the perfect GIS software for processing, checking and digitizing, an increasing number of GIS users worldwide appear to use the open-source GIS software QGIS. Like any GIS software, also QGIS has a lot of pros and cons. Its worldwide user community has created a huge knowledgebase, which can be approached through the Internet. There are a number of discussion forums, blogs, tutorials available on the net.
Always load QGIS as 'Desktop' without GRASS.   

For the installation of QGIS, particularly specific for LUPMIS, see the following chapter.

LUPMIS has various output options to enable import in QGIS:

  • a) Automatic plugin to load map, as generated in LUPMIS

After LUPMIS has generated a map, four display options are dispayed:


If you select 'Show.... in QGIS', the processed map will be displayed in QGIS.

The 'LUPMIS Tools' plugin must be installed (see following chapter). You can call this functionality of adding a map from LUPMIS by Plugins > LUPMIS Tools > Add LUPMIS map. Alternatively, you can use the shortcut from the taskbar (if 'Plugins' is enabled at View > Toolbars), as shown in the image below on the right side.



This will add the recently generated map from LUPMIS as a SHP file, including its data fields of id (e.g. UPN), label (e.g. address), style number (e.g. planning zone), planning zone in words (if applicable), projection (PRJ file) and style (if applicable, QML file).



Technical note: The file from the most recent LUPMIS process is identified in file C:\LUPMIS\LUPMISTemp\Temp_addLayer_QGIS.txt. This will be used for the add-map plugin function in QGIS.

  • b) Convert selected DRA file in LUPMIS to be added in QGIS (as SHP file), including attributes, style, projection

If you have a single GIS file in LUPMIS / Map Maker, you can select it and it will converted to SHP with all support data and displayed in QGIS by Processing Tools > Format conversion > Vector > Convert DRA to SHP > Single map:


The next menu will let you choose, if styles and planning zone names will also be transferred (in case of plans):



First option displays the selected map in a new QGIS, second option enables the call of this map in an already open QGIS, as described in part (a) above.

If there are too many legend entries in the Legend box in QGIS, use the filter command to reduce ('Filter legend by map content').   

See also another example for transfer to QGIS: Permit fee due map with amount in attribute file in Chapter 8.5.5.4.

  • c) Convert selected DRA file in Map Maker to SHP file format

There is also an option in Map Maker to convert a DRA file to SHP format for QGIS: Utilities > Vector utilities > Export files > to ArcView Shape file:


If you have a SHP file from LUPMIS, you can also add the standard colours (styles) to it through: Select added layer > right mouse-click > Properties > Style > Load Style > Select the QML style file you are familiar from Map Maker > Open










  • d) Create a layer in QGIS for LUPMIS

LUPMIS requires the 3 fields of id, label and style for most of its processing. In case, a GIS layer (polygon or line or point file) is set up in QGIS (which is not necessarily the most preferred option), it is better to create such a new layer through the LUPMIS plugin by Plugins > LUPMIS Tools > Create polygon / line / point map for LUPMIS, or alternatively press the shortcut on the taskbar, and enter a name for this new layer:




Don't forget to save regularly, if data are entered.

  

 
Back to content | Back to main menu